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Recommended PC requirements  
Operating System  Windows 11 Pro/Enterprise 64-bit  

Processor    Core i3 8th Gen or newer 

Memory    8 GB or more 

Free Disk Space   250 GB  

Ethernet Ports   2 (One for connection to Maurice or MauriceFlex, second port for 

network access)  

 

Installation  
Open the installer file to start the installation. 

 

NOTE: To see latest installer version, select ‘Check for Updates’ in Help menu. If you don’t have internet 

access, contact ProteinSimple sales or support team for assistance. 

  
Compatibility with Instrument software and Authorization Server 
 

The following software is tested and released with Compass for iCE 4.1.0 

Maurice and MauriceFlex Instrument Software: 4.3 
Instrument software 4.3 Release to support Maurice and MauriceFlex instruments. 

Note: If you are Maurice, Maurice C., or Maurice S. user upgrading from 4.1, you can directly upgrade to 

4.3, as 4.2 was released primarily for MauriceFlex instrument support. 

For compatibility on Maurice instrument software, see ‘Maurice Instrument Software Update Guide’ on 

Bio-Techne website. 

Compass Authorization Server for iCE: 3.0.0 
Compass for iCE 3.0.0 or above users are required to upgrade to Compass Authorization Server for iCE 

version 3.0.0 (if not already) to establish a secure connection between Compass for iCE and 

Authentication server (CAS).  

If Compass for iCE tries to connect to older version of CAS (below version 3.0.0), a warning is displayed 

that Compass Authorization Server is out of date and is connecting in insecure manner. 

For more details, see ‘Compass Authorization Server for iCE Update Guide’ on Bio-Techne website.  

https://www.bio-techne.com/resources/instrument-software-download-center
https://www.bio-techne.com/resources/instrument-software-download-center


4.1.0 Compass for iCE Software 
 

Features 
 

1. Verified with Windows 11 64-bit operating system (CFI-1357). 

2. Removed the constraint in Compass to start a run with expired cartridges (cIEF, CE-SDS Plus, 

Turbo CE-SDS) (CFI-1358). 

Note:  

• Starting a run with expired cartridge is not recommended but allowed for cIEF, CE-SDS 

Plus, Turbo CE-SDS. 

• Compass restricts to start a run with expired Flex cartridge. 

3. When you start a run with an expired cartridge, and if access control is enabled, expired 

cartridge info will be recorded in the audit trail (CFI-1384) 

4. Removed the imposed limit on guaranteed injections from Compass software and cartridges 

(CFI-1376) 

Note: Guaranteed injection limit will be removed only in new cartridges that are shipped starting 

from October 2025 

5. The Twitter feature has been removed from Compass for iCE software (CFI-1324). 

 

Improvements and Fixes 
 

1. Removed the ability to set Fluorescence exposure value to zero for cIEF batch. (CFI-1325). 

2. Fixed the issue with bulk Copy-paste operation for Samples from Excel to Compass batch (CFI-

1352). 

3. Fixed the issue with Internal Standard (IS) where the values were incorrectly displayed when 

switching from charge run to a size run, and similarly, the marker values were incorrectly 

displayed when switching from size to charge run (CFI-1400). 

 

Known Issues 
General 

1. pI marker shift can be observed in ‘View All’ mode when hidden peaks are present (CFI-397 or 

CFI-956 or CFI-1427) 

Workaround: Select View->Show Hidden, which will show the pI marker label at the correct 

position. 

2. When the "Window | Default Layout" is performed, the Focus series and IV plots in the Run 

Summary view do not show data for the selected injection (CFI-1407). 

Workaround: Select an injection to view the data on the Focus series and IV plots 

3. When cIEF post-run cleanup is performed with empty reagent vials, there is no error message 

from the instrument even if post-run cleanup is not successful (CFI-1374). 

4. The area calculation is slightly inaccurate when adjacent peaks share the same boundary (CFI-

1341). 

5. The graph data in the injection report overlaps for two peaks that are very close to each other 

(CFI-1327). 



6. When the LDAP username matches the local user account username, Compass-CAS permits users 

to log in with local user accounts even when LDAP is enabled for that account (CFI-1326). 

7. Peak table does not display data for an injection in ‘view selected’ mode, and export spectra 

does not work when perspective is changed from run summary to analysis (CFI-1297) 

Workaround: Selecting the injection in experiment tab displays peaks table data correctly, and 

switching to ‘View All’ mode resolves export spectra issue. 

8. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in 

Empower.  Compass calculates area based on data rate of 2 Hz, where Empower calculates based 

on time of 1 second (16590) 

9. On rare occasions, some File and Instrument menu options are disabled after the run completes.  

Should you encounter this, simply restart Compass and the menu options will be available again. 

(17061 or CFI-229) 

10. Unable to Save As for opened run when opened folder not reachable (19219 or CFI-240) 

11. Peak Fit Range cannot apply range of min and max for more than one group (18791 or CFI-396)  

12. Compass for iCE displays an alert stating that certain special characters are not allowed in 

instrument name, but allows the user to start a run with that name. If the user does not fix this 

issue by removing the special characters, an error is displayed during the run (CFI-533, CFI-627) 

13. An exception may occur when ‘Instrument->Disconnect’ operation is performed at the end of the 

run (CFI-456) 

14. Export Spectra folder name can be incorrect when multiple run files are opened (CFI-689) 

15. In runs where samples have very little data, CE-SDS Lane View may not display the last two peaks 

of MW ladder. Table and graph data are displayed correctly. (CFI-738) 

16. Java heap space error occurs if one tries to open 25 run files of Turbo batches with 96 injections. 

(CFI-702) 

Note: Recommend opening no more than 15 run files at a time  

17. In run summary view of a controlled run file, batch name is not displayed correctly (CFI-707) 

18. Experiment window doesn’t show the manual peak indicator (green check mark) for manual 

Peak Name when change happens through graph context menu (CFI-742) 

19. Consecutive zooming in multi-lane view resets Y-axis scale (CFI-849) 

20. Position of peak is displayed outside defined boundaries of peak (CFI-1224) 

Workaround: Adjust/change the peak start and end points or peak fit width in analysis settings 

window till you see the peak back in boundaries. 

21. ANDI Export spectra of cIEF runs, when opened in ChromPerfect, always display ‘Absorbance’ on 

Y-axis of ChromPerfect graph even though Compass for iCE sends ‘Fluorescence’ (CFI-1266) 

22. Adding twelve or more pI markers and marker groups in the analysis window and applying them 

results in Compass for iCE showing ‘Java out of memory ‘ error (CFI-1222, CFI-1153) 

23. Some exported data still shows decimal symbols instead of commas in German locale. (CFI-663) 

24. When language is set to German, pI or RMT values in new peak information entry may not 

display correctly due to comma and decimal rules (CFI-690, CFI-1270) 

25. Analysis Options panel is not displayed, and analysis edit window shows an error about invalid 

character entry when locale is set to German (CFI-1271) 



26. Separation time, pI marker parameter changes to certain numeric values in a new method are 

not accepted when locale is set to German (CFI-1269) 

27. Data export will not display names correctly in Chinese locale (CFI-692) 

 

Reports 

1. When the user has selected to create an Injection Report that includes Fitted Peaks and a 

method that does not have any FL exposures, a Null Error will display. (17052 or CFI-228) 

Note: Should you encounter this, simply unselect the Fitted Peaks selection in the Injection 

Report 

2. Blank pages appear in the lane view part of the report if the number of injections is less than 48 

(CFI- 561), in cases where the instrument or Cartridge checkbox is not selected (CFI-637), and in 

runs with very few injections (CFI-736) 

 

CFR 

1. No Audit Trail messages are recorded for import/export of methods (18920 or CFI-255) 

2. Manual Peak changes are removed and logged in history after importing analysis settings (19238 

or CFI-660) 

 

 

4.0.2 Compass for iCE Software (Patch Update) 
 

Improvements and Fixes 
 

1. Fixed the issue of Compass for iCE where non-digital signature actions are not being logged in 

the CAS audit trail due to session expiration between Compass and Compass Authentication 

Server (CFI-1330). 

Note: The session expiration time between Compass and CAS is independent of the Compass 

screen auto-lock inactivity time that the user can set on Compass UI. 

2. Fixed the CAS disable dialog box workflow issue. When Compass is launched in Access Control 

mode and it fails to connect with CAS, the error dialog will appear without the 'Disable' option 

unless Compass was started with 'Run as administrator' (CFI-1335).  

 

 

3.0.1 Compass for iCE Software (Patch update only for Compass for iCE 3.0.0 users) 
 

Compatibility update for 3.0.1 patch release 
  

Compass for iCE 3.0.1 is compatible with Maurice instrument software 4.1 and Compass 

Authorization Server for iCE 3.0.0. 

 

 



Improvements and Fixes 
 

1. Fixed the issue of Compass for iCE where non-digital signature actions are not being logged in 

the CAS audit trail due to session expiration between Compass and Compass Authentication 

Server (CFI-1338). 

Note: This session expiration between Compass and CAS is independent of the Compass screen 

auto-lock inactivity time that the user can set on Compass UI. 

2. Fixed the CAS disable dialog box workflow issue. When Compass is launched in Access Control 

mode and it fails to connect with CAS, the error dialog will appear without the 'Disable' option 

unless Compass was started with 'Run as administrator' (CFI-1340). 

 

4.3 Maurice Instrument Software (Maurice and MauriceFlex instruments) 
 

Note: If not explicitly stated, changes apply for both Maurice and MauriceFlex instrument types. 

Features 
 

1. Added Turbo CE-SDS cartridge support for Maurice Control from Empower software. 

2. Added logic to detect MauriceFlex instrument and send RTV lock status to drivers. 

3. Added features that support manufacturing testing. 

Known Issues 
 

1. PC time zone changes may not be updated correctly in the progress bar and status tab of the 

run. However, there is no impact on run duration (EM-134) 

2. Cartridge self-test time displayed in progress bar is only an estimated time of completion and 

may differ from actual time taken for self-test for each cartridge type (EM-142) 

 

4.0.1 Compass for iCE Software (Patch Update) 
 

Improvements 
 

1. Fixed the issue of Compass for iCE displaying ‘Cannot connect to server’ warning dialog even 

when authentication server was connected (CFI-1316) 

2. Fixed a CE-SDS batch file check issue. On a fresh install of Compass for iCE, when switched from 

‘Analysis’ tab to ‘Batch’ tab, ‘Cannot open Batch’ error dialog no longer appears (CFI-1317)  

 

4.0.0 Compass for iCE Software 
 

Features 
 



1.  Added MauriceFlex instrument and MauriceFlex cartridge support. Compass for iCE 4.0.0, when 

connected to MauriceFlex instrument, will enable you to perform the following batch runs (CFI-

776) 

• cIEF 

• CE-SDS Plus 

• Turbo CE-SDS 

• MauriceFlex cIEF (with Flex cartridge) 

• MauriceFlex Fractionation (with Flex cartridge) 

If you are connected to a standard Maurice, Flex cartridge-based batch names do not appear in 

the File -> New Batch menu. 

2. Removed SDS cartridge support on Maurice and MauriceFlex instrument types. You can open 

SDS run files, but cannot create new batches using the File->Menu option (CFI-601) 

3. Local instrument software updates in Compass for iCE are allowed based on instrument type – 

installer version compatibility. If you try to load Flex installer on a standard Maurice, Compass for 

iCE shows an error dialog (CFI-1107) 

4. Compass for iCE user guide offline copy is no longer installed by default with Compass for iCE 

installer. Latest user guide can be obtained from Bio-Techne website (CFI-1129). 

 

Improvements and Fixes 
 

General 

1. Help resources are moved to Bio-Techne website as proteinsimple.com site retired (CFI-481) 

2. Bio-Techne Academy link is added in the help menu to provide easy access to Bio-Techne’s 

learning portal (CFI-743) 

3. Analysis graph’s zoom feature is improved when auto scale is turned on. Y-axis, along with X-axis, 

can now be adjusted correctly based on selected zoom-in region (CFI-794) 

4. In cIEF Marker graph view, exposure time display for absorbance data now matches the system 

setting displayed in analysis options panel (CFI-419) 

5. Added informational message in instrument properties window to restart compass and 

instrument after selecting ‘Set to PC time’ button (CFI-844) 

6. Ctrl + O operation in Batch perspective now opens 'Open Batch File' window instead of 'Open 

Run File' window (CFI-572) 

7. Starting a run by selecting the ‘Start’ button from a run file is not allowed anymore. Save the 

batch as a new batch if any changes were made, and then start running. Otherwise, Compass for 

iCE displays warning ‘Cannot start a new batch from a run file’ (CFI-591) 

8. ‘Start’ button text changes to ‘Purge’ or ‘Cleanup’ based on next recommended action by 

Compass for iCE (CFI-796, CFI-835) 

9. Compass for iCE now displays ‘File does not contain valid batch’ dialog when invalid or corrupted 

batch files are opened (CFI-925) 

10. Corrected text in Turbo start run dialog to mention word ‘Separation matrix’ instead of ‘Running 

buffer’ (CFI-878) 

11. Updated post-run cleanup recommendation message to remove word 'warranty' (CFI-854) 



12. Export Spectra in text format now adds additional files in the export folder with Sample Names 

under the injection header to support injection name-based analysis (CFI-963) 

13. Corrected tooltip of Markers error symbol "M" as "Markers Error: Not found" instead of 

‘Standards Error: Not found’ (CFI-1002) 

 

History Logs 

In previous versions of Compass for iCE, detailed log entries were computed by analyzing 

differences in edit.xml files. This method is difficult to maintain as we continue to add more 

functionality. Therefore, changed the logging mechanism to track setting changes by user action 

and generate detailed log entries from those changes as they happen. Detailed log entries for 

the most part will appear the same as in previous versions of Compass for iCE. Key differences 

are noted below:  

1. Additional entries appear now when analysis settings are changed because we are just tracking 

the user actions rather than not log anything as there are no net changes. For instance, when 

you perform ‘Hide Peak’ and ‘Unhide Peak’, those actions will be logged.  

2. History logs will no longer contain information about each manual setting that got removed. For 
instance, make multiple manual settings edits for an injection by adding 3 peaks. In previous 
versions, there will be three entries of ‘Removed Peak...’ below ‘Removed sample manual 
settings...’ message. Now, ‘Removed peak...’ entries will not be listed under ‘Removed sample 
manual settings...’ message. No information is lost, but we consolidated changes and logged the 
root change only.   
 

CFR 

1. Saving Run files to local folder from Instrument->Runs action is now recorded in CAS Audit trail, 

CAS for iCE v3.0.0 or higher (CFI-762) 

2. Fixed a scenario where Compass for iCE showed that the user was logged in even though access 

control is disabled (CFI-819) 

3. User without permission to perform a Batch Report generation action is prevented from doing so 

(CFI-1233) 

4. Fixed issue where user with permission to perform plate/injection editing was not able to import 

injections when no group permission is assigned (CFI-1263). 

5. Fixed issue where user with permission to perform method editing was not able to import 

methods when no group permission is assigned. (CFI-1264) 

 

Known Issues 
General 

1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in 

Empower.  Compass calculates area based on data rate of 2 Hz, where Empower calculates based 

on time of 1 second (16590) 

2. On rare occasions, some File and Instrument menu options are disabled after the run completes.  

Should you encounter this, simply restart Compass and the menu options will be available again. 

(17061 or CFI-229) 



3. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass 

software will not automatically prompt the user to perform another Cartridge Purge operation if 

required (16501 or EM-10) 

4. Unable to Save As for opened run when opened folder not reachable (19219 or CFI-240) 

5. Peak Fit Range cannot apply range of min and max for more than one group (18791 or CFI-396) 

6. In some cases where there is a large spike in the data outside of the Marker range, the Marker 

peak is mislabeled for the injection in the Samples -> View All display (17732 or CFI-397) 

7. Injection Groups - Sample group names not displayed or incorrectly displayed for some runs (CFI-

468) 

8. Some exported data still shows decimal symbols instead of commas in German locale. (CFI-663) 

9. When language is set to German, pI or RMT values in new peak information entry may not 

display correctly due to comma and decimal rules (CFI-690, CFI-1270) 

10. Analysis Options panel is not displayed, and analysis edit window shows an error about invalid 

character entry when locale is set to German (CFI-1271) 

11. Separation time, pI marker parameter changes to certain numeric values in a new method are 

not accepted when locale is set to German (CFI-1269) 

12. Data export will not display names correctly in Chinese locale (CFI-692) 

13. Compass for iCE displays an alert stating that certain special characters are not allowed in 

instrument name, but allows the user to start a run with that name. If the user does not fix this 

issue by removing the special characters, an error is displayed during the run (CFI-533, CFI-627) 

14. An exception may occur when ‘Instrument->Disconnect’ operation is performed at the end of the 

run (CFI-456) 

15. Export Spectra folder name can be incorrect when multiple run files are opened (CFI-689) 

16. In runs where samples have very little data, CE-SDS Lane View may not display the last two peaks 

of the MW ladder. Table and graph data are displayed correctly. (CFI-738) 

17. Java heap space error occurs if one tries to open 25 run files of Turbo batches with 96 injections. 

Recommend opening no more than 15 run files at a time (CFI-702) 

18. In run summary view of a controlled run file, batch name is not displayed correctly (CFI-707) 

19. Experiment window doesn’t show the manual peak indicator (green check mark) for manual 

Peak Name when change happens through graph context menu (CFI-742) 

20. Consecutive zooming in multi-lane view resets Y-axis scale (CFI-849) 

21. In some instances, when graph view is changed from ‘View Selected’ to ‘View all’, marker peaks 

appear to be shifted away from the scale (CFI-956) 

Workaround: Adjust baseline settings (window and stiffness) from analysis-> peak fit options.  

22. Position of peak is displayed outside defined boundaries of peak (CFI-1224) 

Workaround: Adjust/change the peak start and end points or peak fit width in analysis settings 

window till you see the peak back in boundaries. 

23. Adding twelve or more pI markers and marker groups in the analysis window and applying them 

results in Compass for iCE showing ‘Java out of memory ‘ error (CFI-1222, CFI-1153) 

24. ANDI Export spectra of cIEF runs, when opened in ChromPerfect, always display ‘Absorbance’ on 

Y-axis of ChromPerfect graph even though Compass for iCE sends ‘Fluorescence’ (CFI-1266) 



25. Peak table does not display data for an injection in ‘view selected’ mode when perspective is 

changed from run summary to analysis (CFI-1297) 

Workaround: Selecting the injection in the experiment tab displays peaks table data correctly 

 

Reports 

1. When the user has selected to create an Injection Report that includes Fitted Peaks and a 

method that does not have any FL exposures, a Null Error will display. Should you encounter this, 

simply unselect the Fitted Peaks selection in the Injection Report (17052 or CFI-228) 

2. Blank pages appear in the lane view part of the report if the number of injections is less than 48 

(CFI- 561), in cases where the instrument or Cartridge checkbox is not selected (CFI-637), and in 

runs with very few injections (CFI-736) 

 

CFR 

1. No Audit Trail messages are recorded for import/export of methods (18920 or CFI-255) 

2. There is no Audit Trail log entry for creating a new Batch in Compass for iCE (19200 or CFI-234) 

3. Manual Peak changes are removed and logged in history after importing analysis settings (19238 

or CFI-660) 

 

4.2 Maurice Instrument Software (for MauriceFlex instruments only) 
 

Note: If you are Maurice, Maurice C., or Maurice S. user, do not use instrument software version 4.2. 

For compatibility on Maurice instrument software, see ‘Maurice Instrument Software Update Guide’ 

on Bio-Techne website. 

 

Features 
 

1. Added MauriceFlex instrument and cartridge support to perform cIEF, CE-SDS Plus Turbo CE-SDS, 

MauriceFlex cIEF, MauriceFlex Fractionation runs on MauriceFlex instrument. 

 

Improvements and Fixes 
 

1. Updated software to record ambient temperature and chamber temperature values correctly in 

the embedded logs as the values were swapped when recording in the log file (EM-240) 

 

Known Issues 
 

1. PC time zone changes may not be updated correctly in the progress bar and status tab of the 

run. However, there is no impact on run duration (EM-134) 

2. Cartridge self-test time displayed in progress bar is only an estimated time of completion and 

may differ from actual time taken for self-test for each cartridge type (EM-142) 

 

https://www.bio-techne.com/resources/instrument-software-download-center


3.0.0 Compass for iCE Software 
 

Features 
1. Added Turbo CE-SDS cartridge support in Compass for iCE to enable Turbo SDS cartridges to run 

on Maurice instruments (CFI-282).  

2. New standalone post-run cleanup method is added to cIEF cartridges (CFI-327).  

3. Added recommendations to perform post-run cleanup process for all cartridge types (CFI-398, 

CFI-394) 

Note: For CE-SDS and SDS Plus, Instrument menu item name 'Cartridge cleanup' is changed to 

'Cartridge post run cleanup' (CFI-328). 

4. When a post run cleanup step is skipped, a warning is displayed in run summary and reports for 

all cartridge types (CFI-464). 

Note: Different post-run cleanup warnings will be displayed when cartridge cleanup is aborted or 

failed (CFI-653, CFI-513, CFI-512).  

5. Cartridge Self-Test option is added for cIEF, SDS, SDS-PLUS, & Turbo CE-SDS cartridges (CFI-465, 

CFI-364, CFI-335).  

6. Cartridge serial number column is added in Instrument Logs dialog to support new cartridge self-

test (CFI-525) 

7. If pressure or vacuum fails to reach target pressure during the run, a warning is displayed in the 

Run Summary perspective (CFI-552) 

8. Added ‘Export logs’ and ‘Send Run File’ options in the help menu to facilitate sending zipped log 

files and run files directly to ProteinSimple Technical support (CFI-443, CFI-342) 

Note: ‘Compass for iCE Log’ option in the help menu is removed (CFI-483) as log files can now be 

saved locally using ‘Export logs’ feature. 

9. ‘Graph Options’ and ‘Lane Options’ (for size cartridge types only) selections are now saved with 

the batch and injection run file, so that user preferences are saved for the next time the run file 

is opened (CFI-216) 

10. Lane view option is added in the injection report. In cases of 96 injections, lane view image is 

printed in two 48-injection image views (CFI-215) 

Note: Lane view option is not supported for auto reports. 

11. Compass for iCE can now securely connect to Compass Authorization Server for iCE (CFI-686).  

Note: If Compass for iCE tries to connect to an older version of CAS, a warning is displayed that 

Compass Authorization Server is out of date and is connecting in an insecure manner (CFI-511) 

 

Improvements and Fixes 
 

General 

1. Updated post-run clean-up dialogs for CE-SDS with emphasis on performing post-run cleanup 

after each run (CFI-388) 

2. An information dialog will be displayed at the end of the run if the selected folder is deleted 

during the run, and then the run file gets saved in the default location C:\Users\.. 

\..\Documents\Compass for iCE\Runs. (CFI-241) 



3. Compass for iCE will save run file with unique name in downloads folder if it identifies an existing 

file with same name (CFI-340).  

Note: Start button will be disabled in start run dialog till unique results file name is entered as a 

preventive measure to avoid duplicate run files at the end of run (CFI-248, CFI-290, CFI-362) 

4. Grouping of data now reports Corrected area instead of Raw Area (CFI-231 or 19157) 

5. Added error dialog to inform that newer batch files cannot be opened in unsupported versions of 

Compass (CFI-691) 

6. Fixed an issue with peak height calculation where peak height did not subtract the baseline when 

the interpolate peak fit setting was applied (CFI-291) 

7. Export Spectra -Text Format: RMT values are now exported correctly in "Sample Baseline 

Corrected vs RMT" table (CFI-145) 

8. Removed unused Log4j library from code to avoid any vulnerability threats (CFI-506) 

9. CE-SDS Lanes - Fixed display issue of overlapping peak labels for peaks that have the same or 

similar RMT or MW values (CFI-270) 

10. Updated view in Method Groups table to list items in the order of method names instead of peak 

names (CFI-523)  

11. New shortcut keys (Ctrl+O and Ctrl+Q) are added to enable users to perform open, run, and 

application exit operations (CFI-447) 

12. %Total in Peaks table is updated to display data with two digits of precision to be consistent with 

calculations across compass platforms (CFI-711) 

 

CFR 

1. Added ‘Stop run’ and ‘Start run’ entries in audit trail (CFI-564) 

2. Added cartridge post-run cleanup status entries (CFI-624) and cartridge serial number (CFI-441) 

info to the audit trail 

 

History logs 

1. Added History log message for "Moved Marker" for CE-SDS Markers when opening run file from 

version 2.0 and earlier (19236 or CFI-242) 

2. Added Baseline type in History log when creating a new peak fit group (19237 or CFI-243) 

3. Added Compass version to Run Summary History Log for Started run log message (CFI-570) 

4. Fixed repeated entry issues in analysis log and run summary history (CFI-578 and CFI-598) 

Reports 

1. Instrument Report now includes Cartridge Clog self-test reports (CFI-379) 

2. Added more details in footer - software name and version number, secure status of PDF, and the 

location of the report file (CFI- 273) 

3. Instrument Report will not include Cartridge Info if Cartridge is not present in the instrument 

(CFI-519) 

4. Fixed the issue of when generating Injection Reports, the selected number does not always 

match the selection in the Experiment table (18744 or CFI-217) 

5. Added error message when attempting to save Injection Reports or Export 

Batch/Methods/Injections to a read-only folder (19215, 19171 or CFI-239, CFI-395) 

 



Known Issues 
 

1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in 

Empower.  Compass calculates area based on data rate of 2 Hz, where Empower calculates based 

on time of 1 second (16590) 

2. On rare occasions, some File and Instrument menu options are disabled after the run completes.  

Should you encounter this, simply restart Compass and the menu options will be available again. 

(17061 or CFI-229) 

3. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass 

software will not automatically prompt the user to perform another Cartridge Purge operation if 

required (16501 or EM-10) 

4. Unable to Save As for opened run when opened folder not reachable (19219 or CFI-240) 

5. Peak Fit Range cannot apply range of min and max for more than one group (18791 or CFI-396) 

6. In some cases where there is a large spike in the data outside of the Marker range, the Marker 

peak is mislabeled for the injection in the Samples -> View All display (17732 or CFI-397) 

7. Injection Groups - Sample group names not displayed or incorrectly displayed for some runs (CFI-

468) 

8. Some exported data still shows decimal symbols instead of commas in German locale. (CFI-663) 

9. When language is set to German, pI values in new peak information entry may not display 

correctly due to comma and decimal rules (CFI-690) 

10. Data export will not display names correctly in Chinese locale (CFI-692) 

11. Occasionally, an exception may occur when ‘Instrument->Disconnect’ operation is performed at 

the end of the run (CFI-456) 

12. Export Spectra folder name can be incorrect when multiple run files are opened (CFI-689) 

13. Ctrl + O operation in Batch perspective opens 'Open Batch File' window instead of 'Open Run 

File' window (CFI-572) 

14. In runs where samples have very little data, CE-SDS Lane View may not display the last two peaks 

of the MW ladder. Table and graph data are displayed correctly. (CFI-738) 

15. Java heap space error occurs if one tries to open 25 run files of Turbo batches with 96 injections. 

Recommend opening no more than 15 run files at a time (CFI-702) 

16. In run summary view of a controlled run file, batch name is not displayed correctly (CFI-707) 

17. Certain special characters are allowed in instrument name in Instrument Properties dialog, but 

Compass for iCE displays an alert that they are not allowed (CFI-533, CFI-627) 

18. Experiment window doesn’t show the manual peak indicator (green check mark) for manual 

Peak Name when change happens through graph context menu (CFI-742) 

19. Consecutive zooming in multi-lane view resets Y-axis scale (CFI-849) 

Reports 

1. When the user has selected to create an Injection Report that includes Fitted Peaks and a 

method that does not have any FL exposures, a Null Error will display. Should you encounter this, 

simply unselect the Fitted Peaks selection in the Injection Report (17052 or CFI-228) 



2. Blank pages appear in the lane view part of the report if the number of injections is less than 48 

(CFI- 561), in cases where the instrument or Cartridge checkbox is not selected (CFI-637), and in 

runs with very few injections (CFI-736) 

3. ANDI Export spectra of cIEF runs, when opened in ChromPerfect, always display ‘Absorbance’ on 

Y-axis of ChromPerfect graph even though Compass for iCE sends ‘Fluorescence’ (CFI-1266) 

 

CFR 

1. No Audit Trail messages are recorded for import/export of methods (18920 or CFI-255) 

2. There is no Audit Trail log entry for creating a new Batch in Compass for iCE (19200 or CFI-234) 

3. Manual Peak changes are removed and logged in history after importing analysis settings (19238 

or CFI-660) 

 

4.1 Maurice Instrument Software 

Features 
1. Support to perform Turbo CE-SDS cartridge runs from Maurice instrument (EM-46). 

2. Support to perform post-run cleanups and cartridge self-test to improve the quality and 

durability of the cartridges (EM-12) 

Known Issues 
1. PC time zone changes may not be updated correctly in the progress bar and status tab of the 

run. However, there is no impact on run duration (EM-134) 

2. Cartridge self-test time displayed in progress bar is only an estimated time of completion and 

may differ from actual time taken for self-test for each cartridge type (EM-142) 

 

2.2.0 Compass for iCE Software 

Features 
 

1. Added reconstructed pseudo gel view display for CE-SDS and CE-SDS PLUS application data.  This 

display is an image used for quick qualitative visualization or results, not for quantitation or 

reporting (16142, 16222) 

2. Ability to configure whether Batch and Injection reports are secured by a random password upon 

creation.  Report footer will indicate whether the report PDF was generated with or without the 

(SECURED) option (18135, 18734, 18345)   

3. Compass for iCE will automatically create a single, combined report PDF file with the included 

options selected by the user for Injection Reports (17572, 17559, 18332) 

4. When naming Injection Report filenames, the software will append sample ID to the name of the 

PDF report generated (17982) 

5. Created new group in Analysis Preferences -> Analysis Export to give the user the ability to 

specify Y-Axis units for Absorbance values for ANDI export (17651) 

 

Improvements and Fixes 
 



General 

1. Resolved minor discrepancy in the Peak Position value shown in the Compass for iCE Peaks table 

and the data exported using File -> Export Tables function (18658) 

*NOTE: For both the ‘Markers’ and ‘Samples’ view Peaks table, we have modified the 

application to display the Peak Position and corresponding Height as the value found from the 

peak fit step, not the peak find step in the peak detection algorithms. This value is an 

interpolated pixel position value and is what is currently being exported to the text files when 

using File -> Export Tables.  For consistency, the Peak position values are now displayed AND 

exported with #.0 precision. 

2. For CE-SDS runs, draw Internal Standard (IS) graph line to match time value in Peaks table 

(19097) 

3. Resolved issue where Batch Injection IDs and Injection Names are not updated correctly when 

user switches plate type, e.g., from 96-well plate to 48 vials. (18638) 

4. Fixed issue where loading Batch file from version 2.0 and earlier with a combination of OBM and 

non-OBM injections would not load and display properly in version 2.1 (18714, 18924) 

5. Fixed issue with the Analysis Options Injects field in distinguishing between a custom filter 

expression and a name.  If the name is made up of only characters that can occur in a custom 

filter expression, the name is interpreted as a custom filter (19203) 

6. Resolved compatibility issue for CE-SDS Markers Analysis Groups created with version 2.0 and 

earlier.  In version 2.1, when changing the Markers Injection to ‘no markers’, the Graph labels 

would still display MW values, which is incorrect (19173) 

7. Modified CE-SDS graph peak label precision for MW to be consistent with Peaks table (19160) 

8. Fixed issue in Injection Reports where the date is missing in the footer when the username, first, 

and last name are greater than 30 characters. Re-arranged footer fields so that name 

information and date are one line and will not run into other text (18599) 

9. Resolved issue in Analysis Injections table where duplicate results are displayed for Injections 

that have Methods with the same pI Markers (18716) 

10. Additional check for missing run name before sending batch from Compass to instrument 

(18358) 

 

CFR 

1. Fixed issue where “Added Marker” History log messages were incorrectly present when 

migrating Marker definitions from version 2.0 or earlier (19191) 

2. Resolved multiple incorrect History log messages for CE-SDS Markers introduced in version 2.1 

(19148) 

3. Modification that requires the user to save a comment for unsaved changes in the Batch before 

starting a run on the instrument (18202) 

4. Improved the Audit Trail log entries for Injection reports, which now show "All Injections" or a 

list of Injections sorted by the Injection name in the list, as well as removing leading comma 

(18742, 18346) 

5. Improved consistency of creating Audit Trail log entries for reports.  Compass for iCE application 

will now create one line each for injection report, analysis report, and batch report (18347) 



 

Export 

1. Resolved issue in creating export directory name with a colon in the name (17625, 17608) 

2. ANDI export – fixed issue with export when Injection name has tab or spaces at the end, replace 

these characters with underscore when writing file names (18549) 

 

Known Issues 
 

1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in 

Empower.  Compass calculates area based on data rate of 2 Hz, where Empower calculates based 

on time of 1 second (16590) 

2. On rare occasions, some File and Instrument menu options are disabled after the run completes.  

Should you encounter this, simply restart Compass and the menu options will be available again. 

(17061) 

3. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass 

software will not automatically prompt the user to perform another Cartridge Purge operation if 

required (16501) 

4. Unable to Save As for opened run when opened folder not reachable (19219) 

5. Peak Fit Range cannot apply range of min and max for more than one group (18791) 

6. In some cases where there is a large spike in the data outside of the Marker range, the Marker 

peak is mislabeled for the injection in the Samples -> View All display (17732) 

7. Certain special characters are allowed in instrument name in Instrument Properties dialog, but 

Compass for iCE displays an alert that they are not allowed (CFI-533, CFI-627) 

8. In run summary view of a controlled run file, batch name is not displayed correctly (CFI-707) 

9. ANDI Export spectra of cIEF runs, when opened in ChromPerfect, always display ‘Absorbance’ on 

Y-axis of ChromPerfect graph even though Compass for iCE sends ‘Fluorescence’ (CFI-1266) 

 

 

 

 

  



Reports 

1. When the user has selected to create an Injection Report that includes Fitted Peaks and a 

method that does not have any FL exposures, a Null Error will display.  Should you encounter 

this, simply unselect the Fitted Peaks selection in the Injection Report (17052) 

 

CFR 

1. No Audit Trail messages are recorded for import/export of methods (18920) 

2. There is no Audit Trail log entry for creating a new Batch in Compass for iCE (19200) 

3. Manual Peak changes are removed and logged in history after importing analysis settings (19238) 

 

4.0 Maurice Instrument Software 

Features 
 

1. Support to run instrument from Compass for iCE or Empower Maurice ICS Driver.  Verification 

testing completed for Compass for iCE version 2.2 and Empower Maurice ICS Driver version 1.0. 

2. Support for optional Maurice CE-SDS System Filter (17860, 17842) 

3. Production support for Mitac Single Board Computers (PD10AI and PD11TI) (18881, 18216-

18220)  

 

 

2.1.0 Compass for iCE Software Released March 8, 2019 

Features 
 

1. Support for new CE-SDS PLUS system (* requires Maurice Instrument Software v3.1 listed below) 

(16137) 

2. Ability to import/export injections from Batch view.  Injections in an open batch or run file can be 

exported to a .csv file.  This allows the user to import injections into another batch later, rather 

than having to enter the information manually (16715) 

3. Support for optional FL458nm fluorescence filter (* requires Maurice Instrument Software v3.1 

listed below) (16140) 

4. Manual Peak Integration features are now available when working on controlled files with Access 

Control enabled.  Any user activities related to moving the start/end of peaks will be logged in 

the History tab view in Run Summary (16228) 

5. Added new ‘Interpolate' option for Baseline type in Peak Fit analysis settings.  When selected,  

Compass for iCE lets you interpolate baselines from the base of each peak that uses Dropped 

Lines integration (16287) 

6. Added new Reference Channel Signal Processing capability for CE-SDS data.  When enabled, the 

Reference Channel Correction automatically removes any signal within a certain range that can 

be attributed to lamp variability (16132) 



7. Added new Baseline Smoothing Signal Processing capability for CE-SDS data.  When enabled, the 

software applies baseline smoothing to CE-SDS data to decrease noise and improve signal-to-

noise ratios. (16133) 

8. Report PDFs generated by Compass for iCE are now secured. They can be viewed and printed but 

can’t be modified (16143) 

9. Ability to configure Auto Lock Inactivity timeout in Preferences.  Default value is 20 minutes 

(16304) 

10. Support detection of CE-SDS cartridge that requires purge before use.  If the CE-SDS cartridge 

you have inserted into the instrument hasn’t been used in more than three months, Compass for 

iCE will display an alert recommending you perform a cartridge purge (16138) 

11. Added new ‘Cartridge Purge’ menu item under Instrument menu to allow the user to start a 

purge protocol without having to open a batch (16380) 

12. Analysis Options panel - Allows for easier access to exposure selection and peak naming from the 

Analysis view without having to open the Analysis dialog (16498) 

13. Support Peak Naming for selected peak on Graph or Peaks table (16307) 

14. Online User Guide and Release Notes (16499) 

 

  



Improvements and Fixes 
 

General 

1. Compass for iCE now prevents multiple users or instances of the software from editing the same 

run file (*.mbz) (6905, 16919, 16941) 

2. Compass for iCE now prevents the user from overwriting an existing batch or run file via the 

File->Save As… menu operation (16722, 16743) 

3. Improved cases where Marker/Standard peaks found in Markers/Standards view are not found 

and displayed in Samples view (13205) 

4. Automatically display self-test results after test has completed (16542) 

5. Added "Injection" column to Group Tables (16869) 

6. Modified default analysis settings for CE-SDS - Internal Standard Time has been changed to 750 

seconds, from 710 seconds (17036) 

7. Resolved issue where software would allow users to exceed CE-SDS batch limitations of 48 

injections during the active run (16066) 

8. Resolved Batch Report issue where replicates Sample ID are not displayed properly (16803) 

9. Resolved case when Compass for iCE software attempts to save an incomplete run file that has 

not been properly downloaded from the instrument.  For this version, Compass will not allow the 

user to Save the file when it is incomplete (15912) 

10. Fixed NPE message and incorrect graph, warning, and peak results in the Analysis perspective for 

cIEF run when one of the method definitions does not specify any Fluorescent images in the 

Detection profile (15369) 

11. Increase thermo wash time in CE-SDS Purge from 5 minutes to 10 minutes (16235) 

 

CFR 

1. Improved Authorization Server Audit Trail messages to include full file path for sign_off, 

save_batchfile, save_runfile, open_batchfile, and save_batchfile events (16744, 16752, 16746, 

16543, 16751) 

2. Software provides warning messages for expired password, blocked user, and no permissions in 

the Lock window (8858) 

3. Audit trail and history log track Export uncontrolled file (16977) 

4. Fixed issue in the Run History log, where analysis changes made during the Pause state of an 

active run are not logged in the file properly (16171) 

5. Fixed issue where the Audit Trail reflects the old filename when saving as a new run file (16729) 

6. Resolved issue where the user could not log out from the application when there is an issue with 

a user account that is currently logged in (16200) 

7. Fixed issue where negative pI values in Compass adversely affect the calibrated data in Empower 

(16940) 

 

  



Export 

1. ANDI Export - Modified Y-axis labels from AU to mAU for Absorbance data, and Y-axis values 

from AU to mAU for CE-SDS data only (15229) 

2. Export Tables – Modified the value of the Position column in the exported text files ONLY to be 

the interpolated pixel peak position.  Note that the Position value in the Peaks table in the 

Compass software displays the integer pixel peak position (11906) 

 

Known Issues 
 

1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in 

Empower.  Compass calculates area based on data rate of 2 Hz, where Empower calculates based 

on time of 1 second (16590) 

2. The ‘Help -> Check for Updates’ function will not work to update to version 2.1.0 from Compass 

for iCE version 2.0.11 and earlier due to changes in Java Runtime Environment (1.7 to 1.8) and 

Eclipse RCP (3.7 to 3.8.2).  Users will need to use the installer for upgrade (16834) 

3. On rare occasions, some File and Instrument menu options are disabled after the run completes.  

Should you encounter this, simply restart Compass and the menu options will be available again. 

(17061) 

4. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass 

software will not automatically prompt the user to perform another Cartridge Purge operation if 

required (16501) 

5. When the user has selected to create an Injection Report that includes Fitted Peaks and a 

method that does not have any FL exposures, a Null Error will display.  Should you encounter 

this, simply unselect the Fitted Peaks selection in the Injection Report (17052)  

6. ANDI Export spectra of cIEF runs, when opened in ChromPerfect, always display ‘Absorbance’ on 

Y-axis of ChromPerfect graph even though Compass for iCE sends ‘Fluorescence’ (CFI-1266) 

 

 

3.1 Maurice Instrument Software 

Features 
 

1. Support for new CE-SDS PLUS system (16241) 

2. Support for optional FL458nm fluorescence filter (16211) 

 

Improvements and Fixes 
 

1. Instrument support to double check Deuterium Lamp is ON before starting the run (15001) 

2. Increase cartridge clean-up water load times by a factor of 1.5x (16974) 

  



2.0.11 Software Released October 26, 2018 

Improvements and Fixes  
 

1. Resolved issue where Compass software could not properly synchronize the instrument time to 

the local PC time for fractional time zone offsets (e.g., India) – (15902) 

2. Access Control – resolved issue where login button is enabled after user enters a value in the 

password field and then removes the entry (15678) 

 

2.0.10 Software Released January 5, 2018 

Improvements and Fixes  
 

1. Fixed CE-SDS ANDI Export Time for Empower – ANDI exported CE-SDS data time unit was 

erroneously modified to seconds in Compass for iCE v2.0, which causes issues with imported 

data in Empower.  This issue was not present in versions 1.0 and 1.1, and in version 2.0.10, this 

issue was fixed by reverting to use minutes for ANDI exported CE-SDS data (13851) 

 

2.0 Software Released June 28, 2017 

Improvements and Fixes 
  

1. Improved the 'Dropped-Lines' Peak Find Area calculation analysis .Improvements to the 

baseline fit for run data - In some cases, versions 1.0 and 1.1 of Compass for iCE may incorrectly 

produce negative baseline values. The negative baseline values are eliminated in Compass for iCE 

v2.0, by modification of the baseline offset. Improvements to the peak fit algorithm - In some 

cases, dropped Line peak fit in versions 1.0 and 1.1 of Compass for iCE doesn’t fully calculate the 

area under the curve (AUC), especially for peaks that have a long "tail". In Compass for iCE v2.0, 

the peak fit algorithm is modified to improve the calculation. 

 

* The changes in baseline value, and the dropped line peak fit in Compass for iCE v2.0, 

may produce different peak area values compared to versions 1.0 and 1.1 of Compass 

for iCE.  Please inquire with ProteinSimple Technical Support if you would like further 

supporting documentation and example data regarding these modifications. 

 

Features 
 

1. Runs can be paused to allow editing of the Batch and adding of samples.  

2. Stopping a run performs cartridge cleanup automatically.  

3. Each injection has a unique editable name.  

4. The Injection Names and Sample IDs can be pasted from a list in Excel or other programs.  

5. The Signal to Noise Ratio is reported for each peak. 

6. Improved reporting  Added the time and temperature of each injection.  

a. Added an option to plot the fitted peaks.  



b. Added an instrument and cartridge report including self-test results.  

c. New reports never overwrite existing reports.  

7. Data and Reports can be automatically exported at the end of each run.  

8. Enables manual peak integration via manual correction of peak start and end, including peak 

combining or splitting.  

9. cIEF has an increased FL calibration load time to ensure full loading.  

10. CE-SDS has an increased wash time to maintain resolution and peak arrival time.  

11. cIEF Absorbance and Fluorescence electropherograms can be overlaid.  

12. Methods can be imported or exported among batches. 

 

  



1.1 Software Features Released September 14, 2016  
  

1. Enables the creation of on-board mixing batches for instruments that are on-board mixing 

capable.  

2. CE-SDS assay has an improved wash step which prevents occasional slow migration time after 

extended storage.  

3. cIEF assay actively monitors for bubbles during sample load, greatly reducing the failure of 

injections due to bubbles.  

4. Automatic re-injection on failed cIEF injections with abnormally low current  

5. Improvements to Reports  

a. Title indicates a controlled or uncontrolled run  

b. Injections indicate if they are within the guaranteed limit for the cartridge  

c. The Run table includes the Compass user name for actions  

d. Added page numbering, page x of y  

6. Improvements to ANDI file exports  

a. Added a Chromeleon 6.8 export preference that corrects the X axis to be in pI units 

padded to start from zero.  

b. Fixed a date format problem in the Spectra Export ANDI format that caused some 

injections imported into Empower to corrupt the project.  

c. Changed the cIEF absorbance data to be the same as the ICE3 format by making two 

changes:  

i. changed the Spectra Export ANDI format to be an array of points starting from 

zero with a value of zero until the first pI value.  

ii. Changed the Spectra Export ANDI format y value to be AU, not mAU.   

  

1.0 Software CD Contents Released March 21, 2016 
  

The CD contains the software installation file and the user guide.  

 

NOTE - Key Improvements are listed in the Release Notes. For detailed Release Notes, including an 

itemized list of ALL issues resolved in the latest release, please e-mail support@proteinsimple.com 

  

  


